Skip to content

XAware Community

Get the Flash Player to see this player.
Flash Image Rotator Module by Joomlashack.
XAware 5.6
Need Help
Webinars and Events
Advanced Tutorials
Webinars and Events

You are here: Home arrow XAware Installation

Installing XAware

 

General Requirements:
The following are the system requirements to run XAware Designer:

  • Eclipse 3.4 or greater (XAware recommends Eclipse 3.4.1 with the JEE Ganymede bundle)
  • Minimum of 1 GB RAM/2 Ghz processor
  • Minimum of 1 GB hard disk space
  • High-resolution monitor (1024x768 or higher)

XAware Net Installers

XAware provides the following net installers:

  • Windows x86 32-bit (with everything - Designer and Engine)
  • *nix (Linux/Unix variant) 32-bit (with everything - Designer and Engine) *

* The designer only runs on a x86, 32-bit machine; to install on another type of machine, use the plug-in installation.

XAware Offline Installers

XAware provides the following offline installers:

  • Linux 32-bit (with everything - Designer and Engine) *
  • Mac OS/X (with no Designer)
  • Windows x86 32-bit (with everything - Designer and Engine) **

* The designer only runs on a x86, 32-bit machine; to install on another type of machine, use the plug-in installation.
** Extract the executable first, and then run the console command.

Console install

For console mode (without a GUI), use -c, like this: XAware_windows_5.4.0.1.exe -c.

XAware Plug-in Installation

This section describes two procedures: one that uses the Eclipse Update Manager feature to guide you through the process of adding or updating a plug-in and one that describes how to manually add the XAware plug-in to an Eclipse installation. The former is the typical case, but there may be circumstances in which a manual installation is desirable. When performing a plug-in installation, be sure to follow all Eclipse recommended procedures for working with plug-ins. 

At a minimum, you should have a valid Eclipse 3.4.1 or later installation with the JEE Ganymede bundle. While the following procedure contains information that is applicable to most typical system configurations, different plug-ins and specific Eclipse variations may require minor changes to the actual procedure.

Note: Before installing the XAware plug-in, ensure that the following virtual memory settings are established in the eclipse.ini file, which is by default located at the root of the Eclipse installation:
-vmargs
-Xms256m
-Xmx1g

  1. Open Eclipse and select Help|Software Updates|Find and Install. The Eclipse Install/Update wizard is displayed. The Feature Updates screen is displayed first.
  2. The next step depends on whether you have previously installed an XAware plug-in to this version of Eclipse.

    A. If you have previously installed an XAware plug-in, select the Search updates of the currently installed features radio button. If you select this option, then the Search Results screen is displayed and you can skip to step 6 below. Please note: The plug-in only contains the XAware Feature and it's associated plugins. XAware Engine is not a part of the plugin and if you are running an XAware Engine, you will need to manually update it to the same version as the plugin.

    B. If you have not previously installed an XAware plug-in or if you want to update only specified plug-ins (rather than all), select the Search for new features to install radio button. Then, click the Next button. If you selected the Search for new features to install radio button, the Update sites to visit screen is displayed.
  3. If XAware is not listed in the Site to include in Search box, click the New Remote Site button. Otherwise, skip ahead to step 5. The New Update Site dialog is displayed.
  4. Enter a name for the product (generally XAware) in the Name field, and the appropriate link to the download site (available from the Download section of the XAware web site) in the URL field. Then click OK. The name you entered is added to the list in the Sites to include in Search box.
  5. Ensure that XAware is selected in the Sites to include in Search box and click Finish. Tip: Depending on your Eclipse installation/configuration, you may need to check additional products in the Sites to include in Search box. After Eclipse locates the sites for the selected products, the Search Results screen is displayed. This screen enables you to select the specific features to install/update. Note that there may be multiple versions of some products (including XAware) available.
  6. Ensure that the desired version of XAware is selected and that all required components in other trees are selected, then click the Select Required button to ensure that all components required by Eclipse/XAware are updated appropriately, then click Next. Note: If you are using the ActiveBPEL™ Designer version of Eclipse, you can expand the trees for all other products selected without specifically selecting components to be updated; with the trees expanded, Eclipse will locate the components of these plug-ins that must be updated in conjunction with XAware. One or more license screens is displayed.
  7. Click the I accept the terms in the license agreement radio button to continue with the installation/update. The installation screen is displayed, showing all of the components selected for installation, their version, size and install location.
  8. Click the Finish button to install/update XAware and any other selected components. The XAware plug-in and any other selected components are installed/updated. Note that this process may take some time - especially if multiple components were selected. You must restart Eclipse before starting any newly installed plug-in.
 

Community Login

Get the Flash Player to see this player.
Flash Image Rotator Module by Joomlashack.
Commercial
Free Training
QuickStart Packages
Image 4 Title
Image 5 Title

Polls

Which data source and BizComponent combinations do you most frequently use?
 

Visit XAware.com